Critical Mozilla Firefox Flaw – Noted 2/1/18

Critical remotely exploitable flaw reported in Mozilla Firefox A critical remotely exploitable flaw in Firefox was revealed today, affecting those on Firefox 56 and 67. The problem was fixed in Firefox 58.0.1, and customers are urged to upgrade as soon … Read More

Call Us Now!